"Page not Found" when I try to reach my site

I am sure the site has been running fine - as far as we can tell. All sites show up from here.

I am sitting about 10 miles away from the datacenter and I can reach all of the sites from here. I have monitoring systems in place that ping all the service ports every minute to warn me of any service outages on our servers and that includes HTML, POP3, SMTP, FTP. Nothing seems to be wrong. I also query computers from around the world to see if they have a problem reaching our servers. So ...... I know the servers are up and running and so is your site.

Apparently a web router somewhere between you and the web server is not refreshing properly and keeps delivering the old version of the web page or that message. If you use Internet Explorer and press "Control F5" on your keyboard then it will force the internet to re-load your website from your site's web server instead of from your hard drive or from the bad router.

Give it a try. If that worked then you need to change a setting in Internet Explorer to load your pages on "Every Visit to the Page" instead of "Automatically". You will find the settings in Internet Explorer under /Tools/Internet Options/General/Temporary Internet Files/Settings/Check for Newer Versions of Stored Pages/Every Visit to the Page

The "Automatically" setting only goes to your hard drive to deliver a page so it isn't the best setting to have because you won't get an accurate view of your web site's most recent changes. When you change the setting to "Every Visit to the Page" it will force your browser to look on the web server every time you ask for any page. Basically the same as hitting "Control F5" every time.
  • 5 Users Found This Useful
Was this answer helpful?

Related Articles

Joomla 1.5.x install - hot tip - extension install problems?

Joomla 1.5.x is a much different animal than Joomla 1.0x - the install does not work exactly like...

Open DNS Server problem

When I go to www.dnsreport.com and enter my domain name to test it I also get an error saying...

My website does not look right on a larger screen

When my website is displayed through explorer on a 17inch monitor compared to a 15inch, the pages...

I have installed a CGI script and it does not work

Almost 9 times out of 10 it is because of file and directory permissions. The "cgi-bin"...

I have made changes to my site but I can't see them.

I have made changes to my website but I can't see them when I visit my site with my web browser....